CVE-2026-70476: FlowiseAI Flowise · Improper Access Control
Affects FlowiseAI FlowiseSource CVE Database V5
Not known to be exploited · CVSS 8.3 High : upgrade to 3.1.2 soon.
Data as of 2 Nov 2026, 22:58 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.1.2, 3.1.3
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade Flowise to 3.1.2; flowiseai/Flowise to 3.1.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FlowiseAIFlowise | Affected
| Fixed in
|
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Flowise to version 3.1.3 or later, where this access control vulnerability has been fixed. No other mitigation steps are indicated by the vendor advisory.
Description
CVE-2026-70476 is an improper access control vulnerability in FlowiseAI Flowise versions prior to 3.1.3. It allows an authenticated attacker to manipulate Stripe subscription operations for other tenants by exploiting insufficient verification of subscription identifiers. This can lead to unauthorized changes in subscription plans or seat quantities, causing financial impact and service disruption. The issue is fixed in version 3.1.3.
References
- github.com/FlowiseAI/Flowise/security/advisories/GHSA-gmmw-qg98-6j6p (opens in a new tab)
- github.com/FlowiseAI/Flowise/pull/6321 (opens in a new tab)
- github.com/FlowiseAI/Flowise/commit/4d7899d02ca370a5510406be5c91483085a412f9 (opens in a new tab)
- github.com/FlowiseAI/Flowise/releases/tag/flowise@3.1.3 (opens in a new tab)