Skip to main content
VulnerabilityPublished

CVE-2026-42863: FlowiseAI Flowise · Improper Access Control

Affects FlowiseAI FlowiseSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.6 High : upgrade to 3.1.2 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
7.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.1.2
CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Flowise and flowiseai/Flowise to 3.1.2.

Affected software

ProductAffectedFixed in
FlowiseAIFlowiseAffected
  • <3.1.2
Fixed in
  • 3.1.2
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threatsAffected
  • <3.1.2
Fixed in
  • 3.1.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix for this vulnerability is available in Flowise version 3.1.2. Users and administrators should upgrade to version 3.1.2 or later to remediate this issue. Since this is not a cloud service, patching the affected software is required to address the vulnerability. There is no vendor advisory content contradicting this, so upgrading is the recommended mitigation.

Description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.1.2, a mass assignment vulnerability exists in the chatflow update endpoint of FlowiseAI. The endpoint allows clients to modify server-controlled properties such as deployed, isPublic, workspaceId, createdDate, and updatedDate when updating a chatflow object. Due to missing server-side validation and authorization checks, an authenticated user can manipulate internal attributes of a chatflow and reassign it to another workspace. This allows cross-workspace resource reassignment and unauthorized modification of deployment and visibility settings. This issue has been patched in version 3.1.2.

References

Community reviews

Loading reviews…