Skip to main content
VulnerabilityPublished

CVE-2026-41130: craftcms cms · Server-Side Request Forgery (SSRF)

Affects craftcms cmsSource CVE Database V5

0
Compare

Public exploit available · CVSS 5.5 Medium : upgrade to 5.9.15 or 4.17.9 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.9.15, 4.17.9
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade cms and craftcms/cms to 5.9.15 or 4.17.9.

Affected software

ProductAffectedFixed in
craftcmscmsAffected
  • >=5.0.0-RC1 <5.9.15
Fixed in
  • 5.9.15
craftcmscmsAffected
  • >=4.0.0-RC1 <4.17.9
Fixed in
  • 4.17.9
GitHubcraftcms/cmspkg:github/craftcms/cmsOther threatsAffected
  • <4.17.9
  • <5.9.15
Fixed in
  • 4.17.9
  • 5.9.15

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Craft CMS versions 4.17.9 and 5.9.15. Users should upgrade to these or later versions to remediate the vulnerability. If upgrading is not immediately possible, explicitly restricting the trustedHosts configuration to trusted domains can mitigate the risk by preventing the server from trusting arbitrary Host headers.

Description

Craft CMS versions 4.x through 4.17.8 and 5.x through 5.9.14 contain a Server-Side Request Forgery (SSRF) vulnerability in the resource-js endpoint. This vulnerability arises when the trustedHosts configuration is not explicitly restricted, allowing the application to trust a client-supplied Host header. An attacker can exploit this to control the baseUrl used in prefix validation, causing the server to make arbitrary HTTP requests. Versions 4.

References

Community reviews

Loading reviews…