Skip to main content
VulnerabilityPublished Updated

CVE-2026-41134: microsoft kiota · Code Injection

Affects microsoft kiotaSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.3 High : upgrade to 1.31.1 or 1.29.1 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.31.1, 1.29.1
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade kiota to 1.31.1 or 1.29.1; microsoft/kiota to 1.31.1.

Affected software

ProductAffectedFixed in
microsoftkiotaAffected
  • >=1.30.0 <1.31.1
Fixed in
  • 1.31.1
microsoftkiotaAffected
  • <1.29.1
Fixed in
  • 1.29.1
GitHubmicrosoft/kiotapkg:github/microsoft/kiotaOther threatsAffected
  • <1.31.1
Fixed in
  • 1.31.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Kiota to version 1.31.1 or later, which contains the fix for this vulnerability. Additionally, regenerate or refresh any previously generated clients using the updated Kiota version to replace vulnerable generated code. This ensures that all generated source code is hardened against this injection issue.

Description

Kiota is an OpenAPI based HTTP Client code generator. Versions prior to 1.29.1 and 1.31.1 are affected by a code-generation literal injection vulnerability in multiple writer sinks (for example: serialization/deserialization keys, path/query parameter mappings, URL template metadata, enum/property metadata, and default value emission). When malicious values from an OpenAPI description are emitted into generated source without context-appropriate escaping, an attacker can break out of string literals and inject additional code into generated clients. This issue is only practically exploitable when the OpenAPI description used for generation is from an untrusted source, or a normally trusted OpenAPI description has been compromised/tampered with. Only generating from trusted, integrity-protected API descriptions significantly reduces the risk. To remediate the issue, upgrade Kiota to 1.29.1, 1.31.1, or later and regenerate/refresh existing generated clients as a precaution. Refreshing generated clients ensures previously generated vulnerable code is replaced with hardened output.

References

Community reviews

Loading reviews…