Skip to main content
VulnerabilityPublished

CVE-2026-41180: psi-4ward psitransfer · Path Traversal

Affects psi-4ward psitransferSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 2.4.3 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.3
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade psitransfer and psi-4ward/psitransfer to 2.4.3.

Affected software

ProductAffectedFixed in
psi-4wardpsitransferAffected
  • <2.4.3
Fixed in
  • 2.4.3
GitHubpsi-4ward/psitransferpkg:github/psi-4ward/psitransferOther threatsAffected
  • <2.4.3
Fixed in
  • 2.4.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to psi-4ward psitransfer version 2.4.3 or later, which contains a patch for this vulnerability. Until upgraded, restrict access to the upload endpoint and avoid using custom upload directories with basenames that overlap startup-loaded JavaScript paths. Patch status is not explicitly stated beyond the version 2.4.3 fix; check the vendor advisory for the latest remediation guidance.

Description

CVE-2026-41180 is a path traversal vulnerability in psi-4ward's psitransfer versions prior to 2.4.3. It arises from inconsistent validation of the upload path during the PATCH request flow, allowing an unauthenticated attacker to write files outside the intended directory. Specifically, the vulnerability enables creation of attacker-controlled JavaScript files in the application root, which are executed upon process restart. This can lead to full compromise of the application. A patch fixing this issue is included in version 2.4.3.

References

Community reviews

Loading reviews…