Skip to main content
VulnerabilityPublished

CVE-2026-41206: ParzivalHack PySpector · Incomplete List of Disallowed Inputs

Affects ParzivalHack PySpectorSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 0.1.8 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.1.8
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade PySpector and pyspector to 0.1.8.

Affected software

ProductAffectedFixed in
ParzivalHackPySpectorAffected
  • <0.1.8
Fixed in
  • 0.1.8
PyPIpyspectorpkg:pypi/pyspectorOther threatsAffected
  • <0.1.8
Fixed in
  • 0.1.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade PySpector to version 0.1.8 or later, where the incomplete blocklist issue in PluginSecurity.validate_plugin_code is fixed. No other official remediation or temporary fixes are documented. Patch status is not explicitly confirmed in the vendor advisory, but the version 0.1.8 release addresses the vulnerability.

Description

PySpector versions prior to 0.1.8 contain an incomplete blocklist in the PluginSecurity.validate_plugin_code function, allowing bypass of input restrictions via unfiltered Python constructs. This can enable an attacker who supplies a malicious plugin file to execute arbitrary code within the PySpector process. The issue is fixed in version 0.1.8.

References

Community reviews

Loading reviews…