Skip to main content
VulnerabilityPublished

CVE-2026-41211: voidzero-dev vite-plus · Path Traversal

Affects voidzero-dev vite-plusSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.4 High : upgrade to 0.1.17 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.1.17
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade voidzero-dev vite-plus to 0.1.17.

Affected software

ProductAffectedFixed in
voidzero-devvite-plusAffected
  • <0.1.17
Fixed in
  • 0.1.17
npmvite-pluspkg:npm/vite-plusOther threatsAffected
  • <0.1.17
Fixed in
  • 0.1.17

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade vite-plus to version 0.1.17 or later, where this path traversal vulnerability has been patched. Since the vendor has released a fixed version, applying this official update is the recommended remediation. Patch status is confirmed by the vendor's versioning information. No other mitigations are specified.

Description

CVE-2026-41211 is a path traversal vulnerability in vite-plus versions prior to 0.1.17. The function downloadPackageManager() improperly handles an untrusted version string, allowing an attacker to supply path segments like '.. /' or absolute paths. This can cause vite-plus to delete, replace, or populate directories outside its intended cache location. The vulnerability has a high severity with a CVSS score of 8.4. A patch was introduced in version 0.1.

References

Community reviews

Loading reviews…