Skip to main content
VulnerabilityPublished

CVE-2026-41264: FlowiseAI Flowise · Incomplete List of Disallowed Inputs

Affects FlowiseAI FlowiseSource CVE Database V5

0
Compare

Public exploit available (Metasploit) · CVSS 9.2 Critical : upgrade to 3.1.0 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.7% chance of exploitation in 30 days – higher than 78% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.1.0
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    1 Metasploit module

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Flowise and flowiseai/Flowise to 3.1.0.

Affected software

ProductAffectedFixed in
FlowiseAIFlowiseAffected
  • <3.1.0
Fixed in
  • 3.1.0
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threatsAffected
  • <3.1.0
Fixed in
  • 3.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade FlowiseAI Flowise to version 3.1.0 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is documented. Patch status is confirmed by the vendor stating the fix is in version 3.1.0.

Description

FlowiseAI Flowise versions prior to 3.1.0 contain a critical remote code execution vulnerability (CVE-2026-41264) in the CSV_Agents class. This vulnerability is due to insufficient sandboxing of Python scripts generated by the LLM, which allows unauthenticated attackers to execute arbitrary Python code with the privileges of the Flowise server user. The issue is fixed in version 3.1.0.

References

Community reviews

Loading reviews…