Skip to main content
VulnerabilityPublished

CVE-2026-41268: FlowiseAI Flowise · Improper Input Validation

Affects FlowiseAI FlowiseSource CVE Database V5

0
Compare

Not known to be exploited · 17% EPSS · CVSS 7.7 High : upgrade to 3.1.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
17.4% chance of exploitation in 30 days – higher than 97% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.1.0
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Flowise and flowiseai/Flowise to 3.1.0.

Affected software

ProductAffectedFixed in
FlowiseAIFlowiseAffected
  • <3.1.0
Fixed in
  • 3.1.0
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threatsAffected
  • <3.1.0
Fixed in
  • 3.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Flowise to version 3.1.0 or later, where this vulnerability is fixed. Patch status is confirmed fixed in 3.1.0. No other mitigations are indicated.

Description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODE_OPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance. This vulnerability is fixed in 3.1.0.

References

Community reviews

Loading reviews…