Skip to main content
VulnerabilityPublished

CVE-2026-41272: FlowiseAI Flowise · Server-Side Request Forgery (SSRF)

Affects FlowiseAI FlowiseSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 3.1.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.1.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Flowise and flowise-components and flowiseai/flowise to 3.1.0.

Affected software

ProductAffectedFixed in
FlowiseAIFlowiseAffected
  • <3.1.0
Fixed in
  • 3.1.0
FlowiseAIflowise-componentsAffected
  • <3.1.0
Fixed in
  • 3.1.0
npmflowiseai/flowisepkg:npm/flowiseai/flowiseOther threatsAffected
  • <3.1.0
Fixed in
  • 3.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix for this vulnerability is available in Flowise version 3.1.0. Since Flowise is a cloud-hosted service, the vendor manages remediation server-side. Users should verify with the vendor advisory that their service instance is updated to version 3.1.0 or later to ensure the vulnerability is mitigated.

Description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, the core security wrappers (secureAxiosRequest and secureFetch) intended to prevent Server-Side Request Forgery (SSRF) contain multiple logic flaws. These flaws allow attackers to bypass the allow/deny lists via DNS Rebinding (Time-of-Check Time-of-Use) or by exploiting the default configuration which fails to enforce any deny list. This vulnerability is fixed in 3.1.0.

References

Community reviews

Loading reviews…