Skip to main content
VulnerabilityPublished

CVE-2026-41274: FlowiseAI Flowise · Improper Neutralization of Special Elements in Data Query Logic

Affects FlowiseAI FlowiseSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical : upgrade to 3.1.0 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.1.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Flowise and flowise-components and flowiseai/Flowise to 3.1.0.

Affected software

ProductAffectedFixed in
FlowiseAIFlowiseAffected
  • <3.1.0
Fixed in
  • 3.1.0
FlowiseAIflowise-componentsAffected
  • <3.1.0
Fixed in
  • 3.1.0
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threatsAffected
  • <3.1.0
Fixed in
  • 3.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Flowise to version 3.1.0 or later, where this vulnerability is fixed. Since this is a self-hosted product, users must apply the update themselves. Patch status is confirmed fixed in 3.1.0. No other mitigations are indicated by the vendor advisory.

Description

Flowise versions prior to 3.1.0 contain a critical vulnerability (CVE-2026-41274) in the GraphCypherQAChain node, where user input is directly passed into the Cypher query execution pipeline without proper sanitization. This allows attackers to inject arbitrary Cypher commands, potentially leading to unauthorized data exfiltration, modification, or deletion on the underlying Neo4j database. The vulnerability is fixed in version 3.1.0. There are no known exploits in the wild at this time.

References

Community reviews

Loading reviews…