CVE-2026-41278: FlowiseAI Flowise · Information Exposure
Affects FlowiseAI FlowiseSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 3.1.0 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.1.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 23 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Flowise and flowiseai/Flowise to 3.1.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FlowiseAIFlowise | Affected
| Fixed in
|
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Flowise to version 3.1.0 or later, where this vulnerability is fixed. Since the vulnerability is resolved in 3.1.0, applying this official fix is the recommended remediation. No other mitigations are specified or required.
Description
CVE-2026-41278 is a high-severity vulnerability in FlowiseAI's Flowise product versions prior to 3.1.0. The GET /api/v1/public-chatflows/:id endpoint returns the full chatflow object without sanitization, exposing sensitive information such as credential IDs, plaintext API keys, and password-type fields. The issue is exacerbated in the released v3.0.13 Docker image, which lacks the sanitization function entirely, leading to raw sensitive data exposure. This vulnerability is fixed in version 3.1.0.