CVE-2026-41280: Apache DolphinScheduler · Incorrect Authorization
Affects Apache DolphinSchedulerSource CVE Database V5
Not known to be exploited · CVSS 4.9 Medium : upgrade to 3.4.2 when convenient.
Data as of 30 Oct 2026, 20:25 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.4.2
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 17 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Apache to 3.4.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache DolphinScheduler | Affected
| Fixed in
|
MavenApache Software Foundation/org.apache.dolphinscheduler:dolphinscheduler-apipkg:maven/Apache Software Foundation/org.apache.dolphinscheduler:dolphinscheduler-apiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Apache DolphinScheduler to version 3.4.2 or later, where this authorization issue has been fixed. No other mitigation or temporary workaround is indicated.
Description
Incorrect Authorization vulnerability allows users with system login privileges to delete task definitions in unauthorized projects This issue affects Apache DolphinScheduler versions prior to 3.4.2. Users are recommended to upgrade to version 3.4.2, which fixes this issue.