Skip to main content
VulnerabilityPublished

CVE-2026-41318: Mintplex-Labs anything-llm · Cross-site Scripting

Affects Mintplex-Labs anything-llmSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.4 Medium : upgrade to 1.12.1 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.12.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade anything-llm and mintplex-labs/anything-llm to 1.12.1.

Affected software

ProductAffectedFixed in
Mintplex-Labsanything-llmAffected
  • <1.12.1
Fixed in
  • 1.12.1
GitHubmintplex-labs/anything-llmpkg:github/mintplex-labs/anything-llmOther threatsAffected
  • <1.12.1
Fixed in
  • 1.12.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in AnythingLLM version 1.12.1 that fixes this vulnerability by properly sanitizing the chart captions. Users should upgrade to version 1.12.1 or later to remediate this issue. No other mitigation is specified or required by the vendor advisory.

Description

CVE-2026-41318 is a stored cross-site scripting (XSS) vulnerability in Mintplex-Labs' AnythingLLM application versions prior to 1.12.1. The issue arises from unsafe handling of markdown image alt text in the in-chat markdown renderer, specifically in the Chartable component, which does not sanitize chart captions. An attacker able to influence the LLM's output can inject malicious scripts that execute in other users' browsers when they view the affected chat. Version 1.12.1 includes a patch addressing this vulnerability.

References

Community reviews

Loading reviews…