Skip to main content
VulnerabilityPublished

CVE-2026-41320: frappe hrms · SQL Injection

Affects frappe hrmsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 15.54.0 or 14.38.1 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 15.54.0, 14.38.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade hrms and frappe/hrms to 15.54.0 or 14.38.1.

Affected software

ProductAffectedFixed in
frappehrmsAffected
  • <15.54.0
Fixed in
  • 15.54.0
frappehrmsAffected
  • <14.38.1
Fixed in
  • 14.38.1
GitHubfrappe/hrmspkg:github/frappe/hrmsOther threatsAffected
  • <15.54.0
  • <14.38.1
Fixed in
  • 15.54.0
  • 14.38.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Frappe HRMS to version 15.54.0 or 14.38.1 or later to apply the official patch. No workarounds are available, so patching is the only effective mitigation.

Description

CVE-2026-41320 is a medium severity SQL injection vulnerability in the Frappe HRMS product. Versions prior to 15.54.0 and 14.38.1 are affected. An attacker can send a specially crafted request to a certain endpoint to extract unauthorized information via SQL injection. The vulnerability has been patched in versions 15.54.0 and 14.

References

Community reviews

Loading reviews…