CVE-2026-41433: open-telemetry opentelemetry-ebpf-instrumentation · Path Traversal
Affects open-telemetry opentelemetry-ebpf-instrumentationSource CVE Database V5
Not known to be exploited · CVSS 8.4 High : upgrade to 0.8.0 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.8.0
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 24 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade opentelemetry-ebpf-instrumentation and open-telemetry/opentelemetry-ebpf-instrumentation to 0.8.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| open-telemetryopentelemetry-ebpf-instrumentation | Affected
| Fixed in
|
GitHubopen-telemetry/opentelemetry-ebpf-instrumentationpkg:github/open-telemetry/opentelemetry-ebpf-instrumentationOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade opentelemetry-ebpf-instrumentation to version 0.8.0 or later, where this vulnerability is fixed. If upgrading immediately is not possible, consider disabling Java injection or running the instrumentation with least privileges to reduce risk.
Description
CVE-2026-41433 is a path traversal vulnerability in open-telemetry's opentelemetry-ebpf-instrumentation versions 0.4.0 up to but not including 0.8.0. It allows a local attacker controlling a Java workload to overwrite arbitrary host files when Java injection is enabled and the instrumentation runs with elevated privileges. The flaw arises because the injector trusts the TMPDIR environment variable from the target process and uses unsafe file creation methods, enabling filesystem boundary escape and symlink-based file overwriting. This vulnerability is fixed in version 0.8.0.