CVE-2026-41577: goauthentik authentik · Insufficient Verification of Data Authenticity
Affects goauthentik authentikSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 2026.2.3 or 2025.12.5 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2026.2.3, 2025.12.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade authentik and github.com/goauthentik/authentik to 2026.2.3 or 2025.12.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| goauthentikauthentik | Affected
| Fixed in
|
| goauthentikauthentik | Affected
| Fixed in
|
Gogithub.com/goauthentik/authentikpkg:golang/github.com/goauthentik/authentikOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available and has been implemented in authentik versions 2025.12.5 and 2026.2.3. Users should upgrade to at least these versions to remediate the vulnerability. No additional mitigation actions are indicated by the vendor advisory.
Description
authentik is an open-source identity provider. Prior to versions 2025.12.5 and 2026.2.3, the SAML source response processor (ResponseProcessor.parse()) does not validate the Conditions element on assertions. NotBefore, NotOnOrAfter, and AudienceRestriction are all ignored. This allows replay of expired assertions and acceptance of assertions intended for other service providers. This issue has been patched in versions 2025.12.5 and 2026.2.3.