Skip to main content
CVE-2024-10977VulnerabilityPublished Updated

PostgreSQL · Client Use of Server Error Message

Affects postgresqlSource GCVE Database

0
Compare
Authoritative record:CVE-2024-10977· Low 3.1

Not known to be exploited · CVSS 3.1 Low · fixed in 17.1 : update postgresql when convenient.

Data as of 29 Oct 2026, 22:59 UTC

CVSS 3.1 base score
3.1Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (PostgreSQL)CVSS 3.13.1
Patch
Available – fixed in 17.1, 16.5, 15.9 +3
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Postgresqlpostgresql/postgresqlpkg:deb/postgresql/postgresqlOther threatsAffected
  • <17.1
  • <16.5
  • <15.9
  • <14.14
  • <13.17
  • <12.21
Fixed in
  • 17.1
  • 16.5
  • 15.9
  • 14.14
  • 13.17
  • 12.21

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected PostgreSQL installations to versions 17.1, 16.5, 15.9, 14.14, 13.17, or 12.21 or later where this issue is fixed. No other specific mitigations are indicated.

Description

A vulnerability in PostgreSQL client handling of server error messages allows an untrusted server under current SSL or GSS settings to send arbitrary non-NUL bytes to the libpq application. This can cause a man-in-the-middle attacker to craft long error messages that might be mistaken by users or screen-scrapers for valid query results. The issue affects PostgreSQL versions prior to 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21.

References

Community reviews

Loading reviews…