CVE-2024-10977: PostgreSQL · Use of Less Trusted Source
Affects PostgreSQLSource CVE Database V5
Not known to be exploited · CVSS 3.1 Low · fixed in 17.1 : update PostgreSQL when convenient.
Data as of 26 Oct 2026, 15:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.1, 16.5, 15.9 +3
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 16 Nov 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Postgresqlpostgresql/postgresqlpkg:deb/postgresql/postgresqlOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should promptly upgrade PostgreSQL installations to the fixed versions: 17.1, 16.5, 15.9, 14.14, 13.17, or 12.21. Network security should be enhanced to prevent man-in-the-middle attacks, including enforcing strict SSL/TLS configurations and validating server certificates rigorously. Client applications using libpq should be audited to ensure they clearly distinguish error messages from query results, possibly by updating client software or adding explicit parsing logic. Implementing network segmentation and monitoring for unusual error message patterns can help detect attempted exploitation. Additionally, educating users and administrators about the risks of interpreting error messages as valid data can reduce the impact of potential attacks. Regular vulnerability scanning and patch management processes should be enforced to maintain updated PostgreSQL versions.
Description
Client use of server error message in PostgreSQL allows a server not trusted under current SSL or GSS settings to furnish arbitrary non-NUL bytes to the libpq application. For example, a man-in-the-middle attacker could send a long error message that a human or screen-scraper user of psql mistakes for valid query results. This is probably not a concern for clients where the user interface unambiguously indicates the boundary between one error message and other text. Versions before PostgreSQL 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21 are affected.