CVE-2026-41586: hyperledger fabric · Deserialization of Untrusted Data
Affects hyperledger fabricSource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 2.2.27 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.2.27
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 7 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade org.hyperledger/fabric to 2.2.27.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| hyperledgerfabric | Affected
| Fixed in– |
Mavenorg.hyperledger/fabricpkg:maven/org.hyperledger/fabricOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, consider restricting access to affected components and avoid processing untrusted serialized data if possible.
Description
CVE-2026-41586 is a critical vulnerability in Hyperledger Fabric versions 1.0.0 through 2.2.26 involving unsafe deserialization of untrusted data. The vulnerability arises because Channel.java calls ObjectInputStream.readObject() on untrusted byte arrays without an ObjectInputFilter, leading to a classic Java deserialization remote code execution (RCE) pattern. No patches or official fixes are available at the time of publication. The vulnerability has a high CVSS 4.