Skip to main content
VulnerabilityPublished Updated

CVE-2026-41645: projectdiscovery nuclei · Code Injection

Affects projectdiscovery nucleiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.8.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.8.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade nuclei and projectdiscovery/nuclei to 3.8.0.

Affected software

ProductAffectedFixed in
projectdiscoverynucleiAffected
  • >=3.0.0 <3.8.0
Fixed in
  • 3.8.0
GitHubprojectdiscovery/nucleipkg:github/projectdiscovery/nucleiOther threatsAffected
  • <3.8.0 >=3.0.0
Fixed in
  • 3.8.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Nuclei to version 3.8.0 or later, where this vulnerability has been patched. If upgrading immediately is not possible, ensure that the -env-vars / -ev option remains disabled (the default setting) to avoid exposure of host environment variables. No other mitigations are specified or required.

Description

Nuclei is a vulnerability scanner built on a simple YAML-based DSL. From version 3.0.0 to before version 3.8.0, a vulnerability in Nuclei's expression evaluation engine makes it possible for a malicious target server to inject and execute supported DSL expressions. This happens when HTTP response data containing helper/function syntax gets reused by multi-step templates. If the -env-vars / -ev option is explicitly enabled, this can expose host environment variables. That option is off by default, so standard configurations are not affected by the information disclosure risk. This issue has been patched in version 3.8.0.

References

Community reviews

Loading reviews…