Skip to main content
VulnerabilityPublished

CVE-2026-41646: projectdiscovery nuclei · Improper Access Control

Affects projectdiscovery nucleiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.5 Medium : upgrade to 3.8.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.8.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade projectdiscovery nuclei to 3.8.0.

Affected software

ProductAffectedFixed in
projectdiscoverynucleiAffected
  • >=3.0.0 <3.8.0
Fixed in
  • 3.8.0
GitHubprojectdiscovery/nucleipkg:github/projectdiscovery/nucleiOther threatsAffected
  • =3.0.0
  • =3.8.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Nuclei to version 3.8.0 or later, where this vulnerability has been patched. Since the vendor advisory confirms the fix in 3.8.0, applying this update fully mitigates the issue. No additional mitigations are indicated.

Description

Nuclei versions from 3.0.0 up to but not including 3.8.0 contain an improper access control vulnerability in the JavaScript protocol runtime. This flaw allows JavaScript templates to bypass local file access restrictions and read local . js and . json files via the require() function. The vulnerability is addressed in version 3.8.

References

Community reviews

Loading reviews…