Skip to main content
VulnerabilityPublished

CVE-2026-41680: markedjs marked · Uncontrolled Resource Consumption

Affects markedjs markedSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 18.0.2 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.0.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade markedjs marked to 18.0.2.

Affected software

ProductAffectedFixed in
markedjsmarkedAffected
  • >=18.0.0 <18.0.2
Fixed in
  • 18.0.2
npmmarkedjs/markedpkg:npm/markedjs/markedOther threatsAffected
  • =18.0.0
  • =18.0.1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade marked to version 18.0.2 or later, where this vulnerability is fixed. Patch status is confirmed by the version range and fixed version information. No other mitigations are specified or required.

Description

Marked versions 18.0.0 and 18.0.1 contain a critical denial of service vulnerability caused by an infinite recursion loop triggered by a specific 3-byte input sequence (tab, vertical tab, newline). This leads to unbounded memory allocation and crashes the host Node.js application due to out-of-memory conditions. The vulnerability is fixed in version 18.0.2.

References

Community reviews

Loading reviews…