Skip to main content
VulnerabilityPublished

CVE-2026-41683: i18next-http-middleware · Cross-site Scripting

Affects i18next-http-middlewareSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 3.9.3 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.9.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade i18next-http-middleware to 3.9.3.

Affected software

ProductAffectedFixed in
i18nexti18next-http-middlewareAffected
  • <3.9.3
Fixed in
  • 3.9.3
npmi18next-http-middlewarepkg:npm/i18next-http-middlewareOther threatsAffected
  • <3.9.3
Fixed in
  • 3.9.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in i18next-http-middleware version 3.9.3. Users should upgrade to version 3.9.3 or later to remediate this issue. No official remediation level is provided beyond this patch. Patch status is confirmed by the vendor advisory stating the fix is included in version 3.9.3. If upgrading is not immediately possible, carefully validate and sanitize user-controlled language inputs to prevent injection of CRLF sequences, though this is a temporary measure.

Description

i18next-http-middleware is a middleware to be used with Node.js web frameworks like express or Fastify and also for Deno. Prior to version 3.9.3, i18next-http-middleware wrote user-controlled language values into the Content-Language response header after passing them through utils.escape(), which is an HTML-entity encoder that does not strip carriage return, line feed, or other control characters. When the application used an older i18next (< 19.5.0) that still exercised the backward-compatibility fallback at LanguageDetector.js:100 or otherwise produced a raw detected value, CRLF sequences in the attacker-controlled lng parameter reached res.setHeader('Content-Language', ...) verbatim. This issue has been patched in version 3.9.3.

References

Community reviews

Loading reviews…