Skip to main content
VulnerabilityPublished Updated

CVE-2026-41846: Spring Framework · Cross-site Scripting

Affects Spring FrameworkSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.9 Medium · fixed in 7.0.7.1 : update Spring Framework when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.7.1, 6.2.18.1, 6.1.28 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Spring Framework to 7.0.7.1, 6.2.18.1, 6.1.28 or 5.3.49.

Affected software

ProductAffectedFixed in
SpringSpring FrameworkAffected
  • >=7.0.0 <7.0.7.1
Fixed in
  • 7.0.7.1
SpringSpring FrameworkAffected
  • >=6.2.0 <6.2.18.1
Fixed in
  • 6.2.18.1
SpringSpring FrameworkAffected
  • >=6.1.0 <6.1.28
Fixed in
  • 6.1.28
SpringSpring FrameworkAffected
  • >=5.3.0 <5.3.49
Fixed in
  • 5.3.49

AI-suggested

If you cannot patch yet, developers should avoid accepting untrusted input in the cssClass, cssErrorClass, or cssStyle attributes of JSP form tags or implement manual input validation and output encoding to mitigate injection risks.

Description

A cross-site scripting (XSS) vulnerability exists in Spring Framework's MVC component where user-supplied values in the cssClass, cssErrorClass, or cssStyle attributes of JSP form tags are not properly neutralized. This allows injection of arbitrary HTML or JavaScript code. The vulnerability affects multiple versions of Spring Framework including 5.3.0 through 5.3.48, 6.1.0 through 6.1.27, 6.2.0 through 6.2.18, and 7.0.0 through 7.0.7. The CVSS score is 5.9, indicating a medium severity level.

References

Community reviews

Loading reviews…