CVE-2026-41889: jackc pgx · SQL Injection
Affects jackc pgxSource CVE Database V5
Not known to be exploited · CVSS 2.3 Low : upgrade to 5.9.2 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.9.2
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade pgx and github.com/jackc/pgx to 5.9.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| jackcpgx | Affected
| Fixed in
|
Gogithub.com/jackc/pgxpkg:golang/github.com/jackc/pgxOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to pgx version 5.9.2 or later, where this SQL injection vulnerability has been fixed. No other mitigation steps are indicated by the vendor advisory.
Description
CVE-2026-41889 is a low-severity SQL injection vulnerability in the jackc pgx PostgreSQL driver for Go. It affects versions prior to 5.9.2 when using the non-default simple protocol with dollar quoted string literals that contain text interpreted as placeholders controllable by an attacker. This vulnerability has been patched in version 5.9.2.