CVE-2026-41887: flarum framework · Path Traversal
Affects flarum frameworkSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 4.9 Medium : upgrade to 2.0.0-rc.1 or 1.8.16 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.0.0-rc.1, 1.8.16
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 8 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade framework to 2.0.0-rc.1 or 1.8.16; flarum/framework to 1.8.16.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| flarumframework | Affected
| Fixed in
|
| flarumframework | Affected
| Fixed in
|
GitHubflarum/frameworkpkg:github/flarum/frameworkOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability has been patched in Flarum versions 1.8.16 and 2.0.0-rc.1. Users should upgrade to these or later versions to remediate the issue. No vendor advisory was provided to indicate alternative mitigations or temporary fixes. Patch status is confirmed by the version information in the description.
Description
Flarum is open-source forum software. Prior to versions 1.8.16 and 2.0.0-rc.1, Flarum's patch for CVE-2023-27577 restricted the @import and data-uri() LESS features in the custom_less setting, but the same restriction was never applied to other settings registered as LESS config variables (for example theme_primary_color and theme_secondary_color, as well as any key registered via Extend\Settings::registerLessConfigVar()). Those values are interpolated verbatim into the LESS source at compile time, allowing an authenticated administrator to craft a theme-color value that injects an arbitrary @import directive into the compiled forum.css. Because the underlying LESS parser honours @import (inline) '<path>', an attacker can read arbitrary files reachable by the PHP process (local file inclusion) or trigger outbound HTTP(S) requests (server-side request forgery). This issue has been patched in versions 1.8.16 and 2.0.0-rc.1.
References
- github.com/flarum/framework/security/advisories/GHSA-xjvc-pw2r-6878 (opens in a new tab)
- github.com/flarum/framework/commit/2d90a1f19f0e46f8c7e1b07c48ba74b5e38f8410 (opens in a new tab)
- github.com/flarum/framework/releases/tag/v1.8.16 (opens in a new tab)
- github.com/flarum/framework/releases/tag/v2.0.0-rc.1 (opens in a new tab)