CVE-2026-41891: ci4-cms-erp ci4ms · Insufficient Session Expiration
Affects ci4-cms-erp ci4msSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 0.31.8.0 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.31.8.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 7 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade ci4ms and ci4-cms-erp/ci4ms to 0.31.8.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ci4-cms-erpci4ms | Affected
| Fixed in
|
GitHubci4-cms-erp/ci4mspkg:github/ci4-cms-erp/ci4msOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade ci4ms to version 0.31.8.0 or later, where the issue has been patched by restoring the deactivated/banned user check in the authentication filter. No other specific mitigations are indicated. Patch status is confirmed by the vendor's versioning information.
Description
CI4MS, a CodeIgniter 4-based CMS skeleton, had an insufficient session expiration vulnerability in versions from 0.26.0 up to but not including 0.31.8.0. Specifically, the authentication filter had the deactivated or banned user check commented out, potentially allowing sessions to remain valid longer than intended. This issue has been addressed and patched in version 0.31.8.