Skip to main content
VulnerabilityPublished

CVE-2026-42047: inngest-js · Information Exposure

Affects inngest-jsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 3.54.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.54.0, 3.54.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade inngest-js to 3.54.0; inngest/inngest-js to 3.54.1.

Affected software

ProductAffectedFixed in
inngestinngest-jsAffected
  • >=3.22.0 <3.54.0
Fixed in
  • 3.54.0
npminngest/inngest-jspkg:npm/inngest/inngest-jsOther threatsAffected
  • >=3.22.0 <3.54.1
Fixed in
  • 3.54.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version (3.54.0) of inngest-js is available and should be applied to remediate this vulnerability. If upgrading immediately is not feasible, restrict the serve() endpoint at the application framework or reverse-proxy level to accept only GET, POST, and PUT HTTP methods, as the serve() handler does not require other methods. This restriction prevents the diagnostic handler from exposing environment variables via PATCH, OPTIONS, or DELETE requests.

Description

A vulnerability in inngest-js versions 3.22.0 through 3.53.1 allows unauthenticated remote attackers to exfiltrate environment variables via the serve() HTTP handler when accessed with PATCH, OPTIONS, or DELETE requests. This exposure occurs because the diagnostic response to these methods includes the full contents of process.env, potentially leaking secrets, API keys, or credentials. Applications exposing the serve() endpoint to these HTTP methods are vulnerable, which is common in some frameworks like Next.js Pages Router or Express using app.use(...

References

Community reviews

Loading reviews…