Skip to main content
VulnerabilityPublished

CVE-2026-42449: czlonkowski n8n-mcp · Server-Side Request Forgery (SSRF)

Affects czlonkowski n8n-mcpSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.5 High : upgrade to 2.47.14 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.47.14
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade n8n-mcp and czlonkowski/n8n-mcp to 2.47.14.

Affected software

ProductAffectedFixed in
czlonkowskin8n-mcpAffected
  • >=2.47.4 <2.47.14
Fixed in
  • 2.47.14
GitHubczlonkowski/n8n-mcppkg:github/czlonkowski/n8n-mcpOther threatsAffected
  • >=2.47.4 <2.47.14
Fixed in
  • 2.47.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version 2.47.14 of n8n-mcp is available and should be applied to remediate this vulnerability. If immediate upgrade is not possible, users should validate URLs before passing them to the SDK to ensure they do not point to internal or sensitive endpoints. Additionally, restricting egress network traffic to prevent unauthorized outbound requests and rejecting user-controlled n8nApiUrl values can mitigate exploitation risk. The first-party HTTP server deployment is less affected due to an additional asynchronous validator, but upgrading is still recommended.

Description

### Impact In the SDK embedder path (`N8NDocumentationMCPServer` constructor, `getN8nApiClient()`, and `validateInstanceContext()`), the synchronous URL validator in `SSRFProtection.validateUrlSync()` had no IPv6 checks. IPv4-mapped IPv6 addresses such as `http://[::ffff:169.254.169.254]` bypassed the cloud-metadata, localhost, and private-IP range checks. An attacker able to supply an `n8nApiUrl` value could cause the server to issue HTTP requests to cloud metadata endpoints (AWS IMDS, GCP, Azure, Alibaba, Oracle), RFC1918 private networks, or localhost services. Response bodies are returned to the caller (non-blind SSRF), and the `n8nApiKey` is forwarded in the `x-n8n-api-key` header to the attacker-controlled target. The first-party HTTP server deployment was not primarily affected — it has a second async validator (`validateWebhookUrl`) that catches IPv6 addresses. Impact category: **CWE-918** (Server-Side Request Forgery). ### Affected Deployments embedding n8n-mcp as an SDK using `N8NDocumentationMCPServer` or `N8NMCPEngine` with user-supplied `InstanceContext` on versions **v2.47.4 through v2.47.13**. ### Patched **v2.47.14** and later. - npm: `npx n8n-mcp@latest` (or pin to `>= 2.47.14`) - Docker: `docker pull ghcr.io/czlonkowski/n8n-mcp:latest` ### Workarounds If developers cannot upgrade immediately: - **Validate URLs before passing to the SDK** — reject any `n8nApiUrl` whose hostname is an IP literal (bracketed IPv6 or dotted IPv4) before calling `N8NDocumentationMCPServer` / `getN8nApiClient()`. Accept only URLs with DNS-resolvable hostnames. - **Restrict egress at the network layer** — block outbound traffic from the n8n-mcp process to RFC1918 ranges (10.0.0.0/8, 172.16.0.0/12, 192.168.0.0/16), link-local `169.254.0.0/16`, and cloud metadata endpoints. Defense-in-depth against this class of issue and recommended even after upgrading. - **Do not accept user-controlled `n8nApiUrl` values** — if the project's integration derives the URL from internal configuration only, this vulnerability is not reachable. Upgrading to v2.47.14 is still strongly recommended. ### Credit Reported by @manthanghasadiya.

References

Community reviews

Loading reviews…