Skip to main content
VulnerabilityPublished Updated

CVE-2026-42055: F5 NGINX Open Source · Heap-based Buffer Overflow

Affects F5 NGINX Open SourceSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 1.31.2 or 1.30.3 soon.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
6.5% chance of exploitation in 30 days – higher than 93% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.31.2, 1.30.3, R36 P6 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade NGINX to 1.31.2 or 1.30.3 (Open Source); R36 P6 or 37.0.2.1 (Plus).

Affected software

ProductAffectedFixed in
F5NGINX Open SourceAffected
  • >=1.13.10 <1.31.2
Fixed in
  • 1.31.2
F5NGINX Open SourceAffected
  • >=1.30.2 <1.30.3
Fixed in
  • 1.30.3
F5NGINX PlusAffected
  • >=37.0 <37.0.2.1
  • =R36
Fixed in
  • R36 P6
  • 37.0.2.1

AI-suggested

Red Hat has released security updates for NGINX packages on Red Hat Enterprise Linux 10 that address this vulnerability. Applying these official patches will remediate the issue. Users should update to the fixed versions provided by Red Hat as detailed in their advisories (e.g., nginx-1.26.3-6.el10_2.5 and later). Since this is not a cloud service, remediation depends on applying vendor patches. Patch status is confirmed by Red Hat advisories linked in the references. No alternative mitigations or workarounds are indicated in the vendor advisory.

Description

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_proxy_v2_module and ngx_http_grpc_module modules. This vulnerability exists when the proxy_http_version to 2 or grpc_pass directives are used to proxy HTTP/2 traffic, the ignore_invalid_headers directive is set to off, and the large_client_header_buffers directive size is larger than 2 megabytes. A remote, unauthenticated attacker, along with conditions beyond their control, could send large headers while creating an upstream request. This may cause a heap-based buffer overflow in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

References

Community reviews

Loading reviews…