Skip to main content
VulnerabilityPublished

CVE-2026-42076: EvoMap evolver · OS Command Injection

Affects EvoMap evolverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.8 Critical : upgrade to 1.69.3 as a priority.

Data as of 1 Nov 2026, 11:02 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.7% chance of exploitation in 30 days – higher than 77% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.69.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade evolver and evomap/evolver to 1.69.3.

Affected software

ProductAffectedFixed in
EvoMapevolverAffected
  • <1.69.3
Fixed in
  • 1.69.3
GitHubevomap/evolverpkg:github/evomap/evolverOther threatsAffected
  • <1.69.3
Fixed in
  • 1.69.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade EvoMap evolver to version 1.69.3 or later, where this vulnerability has been patched. No other mitigation is indicated by the vendor advisory. Patch status is not explicitly stated but the fix is confirmed in version 1.69.3.

Description

CVE-2026-42076 is a critical OS command injection vulnerability in the EvoMap evolver product prior to version 1.69.3. The vulnerability exists in the _extractLLM() function, which constructs a shell command using unsanitized input and executes it via execSync(). This allows remote attackers to execute arbitrary shell commands on the server by injecting shell metacharacters through the corpus parameter. The issue has been addressed in version 1.69.3. The CVSS score is 9.8, indicating a critical severity with high impact on confidentiality, integrity, and availability.

References

Community reviews

Loading reviews…