Skip to main content
VulnerabilityPublished Updated

CVE-2026-42169: Red Hat Enterprise Linux 9 · Incorrect Calculation of Buffer Size

Affects Red Hat Enterprise Linux 9Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.3 High.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.17.3
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Red Hat Enterprise Linux 9gimpAffected–Fixed in–
Red Hat Enterprise Linux 9.2 Update Services for SAP SolutionsgimpAffected–Fixed in–
Red Hat Enterprise Linux 9.4 Update Services for SAP SolutionsgimpAffected–Fixed in–
Red Hat Enterprise Linux 9.6 Extended Update SupportgimpAffected–Fixed in–
Red Hat Enterprise Linux 6gimpAffected–Fixed in–
Red Hat Enterprise Linux 7gimpAffected–Fixed in–

AI-suggested

A security update for GIMP is available for Red Hat Enterprise Linux 9 and should be applied to remediate this vulnerability. The update is distributed via Red Hat advisories RHSA-2026:50817 and includes fixes for this and related vulnerabilities. No alternative mitigations are currently available or meet Red Hat's criteria for ease of use and applicability. Users should update to the fixed GIMP package version 3.0.4-4.el9_8.9 or later as provided by Red Hat.

Description

A heap-buffer-overflow vulnerability exists in the APNG (Animated PNG) file loader of GIMP. This flaw occurs when the `fcTL` width exceeds the `IHDR` width, leading to pixel data being written past the end of a heap allocation. Additionally, a heap-based buffer overflow exists in the DDS plug-in due to a BPP mismatch in the `load_layer()` function. Both vulnerabilities can be triggered by opening a specially crafted image file, potentially leading to code execution.

References

Community reviews

Loading reviews…