CVE-2026-42203: BerriAI litellm · Template Injection
Affects BerriAI litellmSource CVE Database V5
Not known to be exploited · CVSS 8.6 High : upgrade to 1.83.7 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.83.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade litellm and berriai/litellm to 1.83.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| BerriAIlitellm | Affected
| Fixed in
|
GitHubberriai/litellmpkg:github/berriai/litellmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade LiteLLM to version 1.83.7 or later, where this vulnerability is patched. Since the vendor advisory does not indicate any alternative mitigations or temporary fixes, applying the official update is the recommended remediation. Restrict access to the proxy API key to trusted users to reduce risk until patched.
Description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.80.5 to before version 1.83.7, the POST /prompts/test endpoint accepted user-supplied prompt templates and rendered them without sandboxing. A crafted template could run arbitrary code inside the LiteLLM Proxy process. The endpoint only checks that the caller presents a valid proxy API key, so any authenticated user could reach it. Depending on how the proxy is deployed, this could expose secrets in the process environment (such as provider API keys or database credentials) and allow commands to be run on the host. This issue has been patched in version 1.83.7.
References
- github.com/BerriAI/litellm/security/advisories/GHSA-xqmj-j6mv-4862 (opens in a new tab)
- github.com/BerriAI/litellm/releases/tag/v1.83.7-stable (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-42203 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2467917 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42203.json (opens in a new tab)