Skip to main content
VulnerabilityPublished

CVE-2026-42225: pjsip pjproject · Improper Certificate Validation

Affects pjsip pjprojectSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.2 High : upgrade to 2.17 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.17
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade pjproject and pjsip/pjproject to 2.17.

Affected software

ProductAffectedFixed in
pjsippjprojectAffected
  • <2.17
Fixed in
  • 2.17
GitHubpjsip/pjprojectpkg:github/pjsip/pjprojectOther threatsAffected
  • <2.17
Fixed in
  • 2.17

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to pjproject version 2.17 or later, where this certificate validation issue has been fixed. Since the vulnerability is patched in version 2.17, applying this official fix is the recommended remediation. Patch status is confirmed by the vendor advisory indicating the fix in version 2.17.

Description

CVE-2026-42225 is a high-severity vulnerability in the pjsip pjproject library prior to version 2.17. On GnuTLS builds, the SIP TLS transport component can accept connections with invalid or untrusted certificates even when certificate verification is explicitly enabled. This improper certificate validation issue is identified as CWE-295. The vulnerability has been patched in version 2.17. No known exploits in the wild have been reported.

References

Community reviews

Loading reviews…