Skip to main content
VulnerabilityPublished

CVE-2026-42226: n8n · Missing Authorization

Affects n8nSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 2.17.5 or 1.123.33 soon.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.17.5, 1.123.33
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:L/SC:L/SI:L/SA:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade n8n to 2.17.5 or 1.123.33; n8n-io/n8n to 1.123.33.

Affected software

ProductAffectedFixed in
n8n-ion8nAffected
  • >=2.17.0 <2.17.5
Fixed in
  • 2.17.5
n8n-ion8nAffected
  • <1.123.33
Fixed in
  • 1.123.33
GitHubn8n-io/n8npkg:github/n8n-io/n8nOther threatsAffected
  • <1.123.33
Fixed in
  • 1.123.33

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability has been patched in n8n versions 1.123.33, 2.17.5, and 2.18.0. Users should upgrade to one of these versions or later to remediate the issue. No other mitigation guidance is provided, and patching is the recommended action.

Description

n8n is an open source workflow automation platform. Prior to versions 1.123.33 and 2.17.5, the dynamic-node-parameters endpoints did not verify whether the authenticated caller was authorized to use a supplied credential reference. An authenticated user with access to a shared workflow could supply a foreign credential ID in the request body, causing the backend to decrypt and use that credential in a helper execution path where the caller also controls the destination URL. This allowed the caller to force the backend to authenticate against attacker-controlled infrastructure using a credential belonging to another user, effectively exfiltrating a reusable API key. The issue is not limited to any single node type; any node that resolves credentials dynamically through these endpoints may be affected. This issue has been patched in versions 1.123.33, 2.17.5, and 2.18.0.

References

Community reviews

Loading reviews…