CVE-2026-42252: Apache Airflow · Template Injection
Affects Apache AirflowSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 3.2.2 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.2.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Apache Airflow to 3.2.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Airflow | Affected
| Fixed in
|
PyPIapache-airflowpkg:pypi/apache-airflowOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade to Apache Airflow version 3.2.2 or later, which includes the corrected documentation with explicit shell quoting and safety caveats. The vendor advisory does not indicate a direct code patch but emphasizes the importance of following the updated safe usage patterns. Deployments modeled on the vulnerable documentation example should review and update their DAG code to properly sanitize or quote parameters passed to BashOperator to prevent shell injection.
Description
CVE-2026-42252 is a critical vulnerability in Apache Airflow 3.0.0 related to improper neutralization of special elements in a template engine. The official documentation previously showed an example using BashOperator with unsanitized parameters, which could lead to shell command injection if users with Dag.can_trigger permission supplied malicious input in the conf field. This vulnerability allows authenticated users to execute arbitrary shell commands on the worker. The issue was addressed by correcting the documentation and advising safer usage patterns. Users are recommended to upgrade to Apache Airflow 3.2.2 or later to receive the corrected documentation and avoid this risk.