Skip to main content
VulnerabilityPublished Updated

CVE-2026-42256: ruby net-imap · Use of Blocking Code in Single-threaded, Non-blocking Context

Affects ruby net-imapSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.0 Medium · fixed in 0.6.4 : update ruby net-imap when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.0Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.6.4, 0.5.14, 0.4.24
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade ruby net-imap to 0.6.4, 0.5.14 or 0.4.24.

Affected software

ProductAffectedFixed in
rubynet-imapAffected
  • >=0.6.0 <0.6.4
Fixed in
  • 0.6.4
rubynet-imapAffected
  • >=0.5.0 <0.5.14
Fixed in
  • 0.5.14
rubynet-imapAffected
  • >=0.4.0 <0.4.24
Fixed in
  • 0.4.24

AI-suggested

Upgrading net-imap to versions 0.4.24, 0.5.14, or 0.6.4 or later fully mitigates this vulnerability. Since these patched versions address the issue, users should apply these updates promptly. Patch status is confirmed by the version information in the advisory. No additional vendor advisory content is available to indicate alternative mitigations or that no action is required.

Description

Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. From versions 0.4.0 to before 0.4.24, 0.5.0 to before 0.5.14, and 0.6.0 to before 0.6.4, when authenticating a connection with SCRAM-SHA1 or SCRAM-SHA256, a hostile server can perform a computational denial-of-service attack on the client process by sending a big iteration count value. This issue has been patched in versions 0.4.24, 0.5.14, and 0.6.4.

References

Community reviews

Loading reviews…