CVE-2026-42257: ruby net-imap · CRLF Injection
Affects ruby net-imapSource CVE Database V5
Not known to be exploited · CVSS 5.8 Medium · fixed in 0.6.4 : update ruby net-imap when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.6.4, 0.5.14, 0.4.24
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:N/VI:H/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 9 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade ruby net-imap to 0.6.4, 0.5.14 or 0.4.24.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| rubynet-imap | Affected
| Fixed in
|
| rubynet-imap | Affected
| Fixed in
|
| rubynet-imap | Affected
| Fixed in
|
AI-suggested
This vulnerability has been patched in net-imap versions 0.4.24, 0.5.14, and 0.6.4. Users should upgrade to at least these versions to remediate the issue. No vendor advisory was provided to indicate alternative mitigations or temporary fixes. Patch status is confirmed by the version information in the description.
Description
Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. Prior to versions 0.4.24, 0.5.14, and 0.6.4, several Net::IMAP commands accept a raw string argument that is sent to the server without validation or escaping. If this string is derived from user-controlled input, it may contain contain CRLF sequences, which an attacker can use to inject arbitrary IMAP commands. This issue has been patched in versions 0.4.24, 0.5.14, and 0.6.4.