CVE-2026-42268: ModSecurity · Integer Underflow
Affects ModSecuritySource CVE Database V5
Not known to be exploited · CVSS 8.2 High : upgrade to 3.0.15 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.0.15
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 12 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade ModSecurity and owasp-modsecurity/ModSecurity to 3.0.15.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| owasp-modsecurityModSecurity | Affected
| Fixed in
|
GitHubowasp-modsecurity/ModSecuritypkg:github/owasp-modsecurity/ModSecurityOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade ModSecurity to version 3.0.15 or later, where this vulnerability is fixed. Since no official vendor advisory or patch link is provided, rely on the version upgrade as the remediation. Patch status is confirmed by the version fix information. No additional mitigation steps are indicated.
Description
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.