CVE-2026-42272: dadrus heimdall · Interpretation Conflict
Affects dadrus heimdallSource CVE Database V5
Not known to be exploited · CVSS 7.8 High : upgrade to 0.17.14 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.17.14
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade heimdall and dadrus/heimdall to 0.17.14.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| dadrusheimdall | Affected
| Fixed in
|
GitHubdadrus/heimdallpkg:github/dadrus/heimdallOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade heimdall to version 0.17.14 or later, where this vulnerability is patched. Since this is not a cloud service, remediation requires applying the official fix by updating the software. Patch status is confirmed by the vendor advisory stating the issue is fixed in version 0.17.14.
Description
CVE-2026-42272 is a vulnerability in dadrus heimdall, a cloud native Identity Aware Proxy and Access Control Decision service. Versions prior to 0.17.14 handle URL-encoded slashes (%2F) in a case-sensitive way, contrary to the case-insensitive definition of percent-encoding. This causes the lowercase equivalent (%2f) to be unrecognized and improperly processed when the default setting allow_encoded_slashes is off. This discrepancy can lead to differences in request path interpretation between heimdall and upstream components, potentially allowing authorization bypass. The issue has been fixed in version 0.17.14. The vulnerability has a CVSS 4.
References
- github.com/dadrus/heimdall/security/advisories/GHSA-43jv-5j4x-qv67 (opens in a new tab)
- github.com/dadrus/heimdall/pull/3207 (opens in a new tab)
- github.com/dadrus/heimdall/commit/8b0de6aba23a047cfee3081df878271bb17f4351 (opens in a new tab)
- github.com/dadrus/heimdall/releases/tag/v0.17.14 (opens in a new tab)