CVE-2026-42276: onyx · Insecure Direct Object Reference
Affects onyxSource CVE Database V5
Not known to be exploited · CVSS 4.3 Medium · fixed in 3.2.6 : update onyx when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.2.6, 3.1.6, 3.0.9
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 8 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade onyx to 3.2.6, 3.1.6 or 3.0.9; onyx-dot-app/onyx to 3.0.9.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| onyx-dot-apponyx | Affected
| Fixed in
|
| onyx-dot-apponyx | Affected
| Fixed in
|
| onyx-dot-apponyx | Affected
| Fixed in
|
GitHubonyx-dot-app/onyxpkg:github/onyx-dot-app/onyxOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability has been patched in onyx versions 3.0.9, 3.1.6, and 3.2.6. Users should upgrade to one of these versions or later to remediate the issue. No other mitigation guidance is provided or necessary as the fix is available.
Description
CVE-2026-42276 is an authorization bypass vulnerability in the onyx open-source AI platform affecting versions prior to 3.0.9, 3.1.6, and 3.2.6. The POST /chat/stop-chat-session/{chat_session_id} endpoint allows any authenticated user to stop another user's active chat session without verifying ownership of the session. This enables an attacker who knows a chat session UUID to interrupt another user's LLM generation mid-stream. The vulnerability has been patched in versions 3.