Skip to main content
VulnerabilityPublished

CVE-2026-42277: onyx · Insecure Direct Object Reference

Affects onyxSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium · fixed in 3.2.6 : update onyx when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.2.6, 3.1.6, 3.0.9
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade onyx to 3.2.6, 3.1.6 or 3.0.9; onyx-dot-app/onyx to 3.0.9.

Affected software

ProductAffectedFixed in
onyx-dot-apponyxAffected
  • >=3.2.0 <3.2.6
Fixed in
  • 3.2.6
onyx-dot-apponyxAffected
  • >=3.1.0 <3.1.6
Fixed in
  • 3.1.6
onyx-dot-apponyxAffected
  • <3.0.9
Fixed in
  • 3.0.9
GitHubonyx-dot-app/onyxpkg:github/onyx-dot-app/onyxOther threatsAffected
  • <3.0.9
Fixed in
  • 3.0.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability has been patched in onyx versions 3.0.9, 3.1.6, and 3.2.6. Users should upgrade to at least these versions to remediate the issue. No additional mitigations are specified or required once patched. Patch status is confirmed by the vendor's versioning information.

Description

CVE-2026-42277 is an authorization bypass vulnerability in the onyx open-source AI platform. Before fixed versions 3.0.9, 3.1.6, and 3.2.6, authenticated users could download files uploaded by other users by supplying the file UUID to the GET /chat/file/{file_id} endpoint. The endpoint verified authentication but did not verify file ownership, allowing unauthorized access to confidential files. This vulnerability has been patched in the specified versions.

References

Community reviews

Loading reviews…