CVE-2026-42280: auth0.js · Incorrect Authorization
Affects auth0.jsSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 10.0.0 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 10.0.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 27 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade auth0/auth0.js to 10.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| auth0auth0.js | Affected
| Fixed in– |
npmauth0/auth0.jspkg:npm/auth0/auth0.jsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Auth0.js to version 10.0.0 or later, where this vulnerability is fixed. Since the vulnerability is in a client-side library, applying the official fix by updating the SDK version is the recommended remediation. Patch status is not explicitly confirmed beyond the fix in version 10.0.0, so verify with vendor advisories for any additional guidance.
Description
A vulnerability exists in Auth0.js versions 8.11.0 through 9.32.0 where, under specific conditions, the SDK may improperly return user profile information when presented with a valid access token and a specifically crafted invalid ID token. This incorrect authorization issue is identified as CWE-863 and is fixed in version 10.0.0. The vulnerability has a CVSS score of 7.