Skip to main content
VulnerabilityPublished Updated

CVE-2026-42301: befeleme pyp2spec · Improper Input Validation

Affects befeleme pyp2specSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.8 High : upgrade to 0.14.1 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.14.1
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade befeleme pyp2spec to 0.14.1.

Affected software

ProductAffectedFixed in
befelemepyp2specAffected
  • <0.14.1
Fixed in
  • 0.14.1
PyPIpyp2specpkg:pypi/pyp2specOther threatsAffected
  • <0.14.1
Fixed in
  • 0.14.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade pyp2spec to version 0.14.1 or later where this vulnerability is fixed. Since the patch status is not explicitly stated but the description confirms the issue is patched in 0.14.1, applying this update is the recommended remediation.

Description

pyp2spec generates working Fedora RPM spec file for Python projects. Prior to version 0.14.1, pyp2spec was writing PyPI package metadata (e.g.the summary field) into the generated spec file without escaping RPM macro directives. When a packager then runs rpmbuild, those directives get evaluated, so a malicious package can execute arbitrary commands on the build machine. This issue has been patched in version 0.14.1.

References

Community reviews

Loading reviews…