Skip to main content
VulnerabilityPublished

CVE-2026-42334: Automattic mongoose · Injection

Affects Automattic mongooseSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 6.13.9 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.13.9
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Automattic mongoose to 6.13.9.

Affected software

ProductAffectedFixed in
AutomatticmongooseAffected
  • <6.13.9
  • >=7.0.0 <=7.8.8
  • >=8.0.0 <=8.22.0
  • >=9.0.0 <=9.1.5
Fixed in
  • 6.13.9
npmmongoosepkg:npm/mongooseOther threatsAffected
  • <6.13.9
Fixed in
  • 6.13.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in mongoose versions 6.13.9, 7.8.9, 8.22.1, and 9.1.6. Users should upgrade to these or later versions to remediate the vulnerability. Patch status is not explicitly stated in a vendor advisory, but the fixed versions are clearly identified. No additional mitigation steps are specified.

Description

Mongoose is a MongoDB object modeling tool designed to work in an asynchronous environment. Prior to 6.13.9, 7.8.9, 8.22.1, and 9.1.6, a vulnerability allows bypassing Mongoose’s sanitizeFilter query sanitization mechanism via the $nor operator. When sanitizeFilter is enabled, Mongoose wraps query operators in $eq to neutralize them. However, prior to the fix, $nor was not included in the set of logical operators that are recursively sanitized. Because $nor accepts an array (like $and and $or), and arrays do not trigger hasDollarKeys(), malicious operators such as $ne, $gt, or $regex could be injected inside a $nor clause without being sanitized. This vulnerability is fixed in 6.13.9, 7.8.9, 8.22.1, and 9.1.6.

References

Community reviews

Loading reviews…