CVE-2026-42353: i18next-http-middleware · Path Traversal
Affects i18next-http-middlewareSource CVE Database V5
Not known to be exploited · CVSS 8.2 High : upgrade to 3.9.3 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.9.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 8 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade i18next-http-middleware to 3.9.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| i18nexti18next-http-middleware | Affected
| Fixed in
|
npmi18next-http-middlewarepkg:npm/i18next-http-middlewareOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade i18next-http-middleware to version 3.9.3 or later, where the vulnerability is patched. Since this is a self-hosted middleware component, users must apply the update themselves. Patch status is confirmed by the vendor advisory indicating the fix in version 3.9.3. No additional mitigations are specified.
Description
i18next-http-middleware is a middleware to be used with Node.js web frameworks like express or Fastify and also for Deno. Prior to version 3.9.3, i18next-http-middleware passes the user-controlled lng and ns values from getResourcesHandler directly into i18next.services.backendConnector.load(languages, namespaces, …) without any sanitization. Depending on which backend is configured, the unvalidated path segments enable either path traversal or SSRF. This issue has been patched in version 3.9.3.