CVE-2026-42354: getsentry sentry · Authentication Bypass by Spoofing
Affects getsentry sentrySource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 26.4.1 as a priority.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 26.4.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 8 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade sentry and getsentry/sentry to 26.4.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| getsentrysentry | Affected
| Fixed in
|
GitHubgetsentry/sentrypkg:github/getsentry/sentryOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Sentry to version 26.4.1 or later, where this vulnerability has been patched. Since this is an on-premises product, administrators must apply the update manually. Patch status is confirmed by the vendor advisory stating the fix is included in version 26.4.1. No other mitigations are indicated.
Description
Sentry is an error tracking and performance monitoring tool. From version 21.12.0 to before version 26.4.1, a critical vulnerability was discovered in the SAML SSO implementation of Sentry. The vulnerability allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. The victim email address must be known in order to exploit this vulnerability. This issue has been patched in version 26.4.1.
References
- github.com/getsentry/sentry/security/advisories/GHSA-rcmw-7mc7-3rj7 (opens in a new tab)
- github.com/getsentry/sentry/pull/113720 (opens in a new tab)
- github.com/getsentry/sentry/commit/0c67558ae7fe08738912d4c5233b53ead048da3b (opens in a new tab)
- github.com/getsentry/sentry/releases/tag/26.4.1 (opens in a new tab)