Skip to main content
VulnerabilityPublished

CVE-2026-42360: Apache Airflow · Information Exposure

Affects Apache AirflowSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.2.2 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.2.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Apache Airflow and apache-airflow to 3.2.2.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache AirflowAffected
  • <3.2.2
Fixed in
  • 3.2.2
PyPIapache-airflowpkg:pypi/apache-airflowOther threatsAffected
  • <3.2.2
Fixed in
  • 3.2.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache Airflow to version 3.2.2 or later. This version includes fixes that properly mask nested sensitive keys in rendered template fields, preventing exposure of plaintext secrets. Users who have already upgraded for CVE-2025-68438 should still apply this update to cover nested key paths. No other specific mitigations are indicated.

Description

CVE-2026-42360 is a medium severity vulnerability in Apache Airflow affecting versions prior to 3.2.2. It involves exposure of sensitive information due to improper masking of nested sensitive keys (such as password, token, secret, api_key) in rendered JSON templates when the rendered field length exceeds a configured limit. Authenticated users with permission to read rendered template fields could access plaintext secret values that should have been masked. This issue is a variant of a previously addressed vulnerability (CVE-2025-68438) but affects nested key paths. Users should upgrade to Apache Airflow 3.2.2 or later to remediate this issue.

References

Community reviews

Loading reviews…