CVE-2026-42410: CodexThemes TheGem Theme Elements (for Elementor) · Cross-site Scripting
Affects CodexThemes TheGem Theme Elements (for Elementor)Source CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 5.12.1.1 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.12.1.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 27 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade CodexThemes TheGem Theme Elements (for Elementor) to 5.12.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| CodexThemesTheGem Theme Elements (for Elementor) | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, users should exercise caution with untrusted input and consider applying temporary mitigations such as input validation or content security policies where feasible.
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CodexThemes TheGem Theme Elements (for Elementor) allows DOM-Based XSS.This issue affects TheGem Theme Elements (for Elementor): from n/a before 5.12.1.1.